couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Wenk <a...@nms.de>
Subject Re: [VOTE] Release Apache CouchDB 1.6.0-rc.3
Date Fri, 25 Apr 2014 06:58:02 GMT
James,

did you have the chance to have a look at the problem?

Slowly, the 1.6.0 release is starting to have some "magical barriers" and
fighting against us ...

Thanks everybody for all your incessantly work!

Cheers

Andy


On 23 April 2014 11:03, Mutton, James <jmutton@akamai.com> wrote:

> well, bummer.  Tried 3 times on R14B01, all 3 I get:
> /tmp/couchdb/dist/apache-couchdb-1.6.0/apache-couchdb-1.6.0/_build/../src/couch_replicator/test/07-use-checkpoints.t
> .......... Failed 4/16 subtests
>
> Test Summary Report
> -------------------
> /tmp/couchdb/dist/apache-couchdb-1.6.0/apache-couchdb-1.6.0/_build/../src/couch_replicator/test/07-use-checkpoints.t
>        (Wstat: 0 Tests: 16 Failed: 4)
>   Failed tests:  9, 12-13, 15
> Files=7, Tests=1832, 150 wallclock secs ( 0.81 usr  0.09 sys + 155.32 cusr
> 13.16 csys = 169.38 CPU)
> Result: FAIL
> make[3]: *** [check] Error 1
>
> Unfortunately, I’m needing some sleep then leaving on some vacation for
> the rest of the week.  I’ll see if I can maybe look closer at what’s going
> on locally while on the flight.
>
> </JamesM>
>
> On Apr 23, 2014, at 1:28, Mutton, James <jmutton@akamai.com> wrote:
>
> > It did but others appeared which leads me to suspect my local install of
> erlang, given what it takes to get R14 to build with clang.
> >
> > Failed 4/16 subtests
> >
> /tmp/couchdb/dist/apache-couchdb-1.6.0/apache-couchdb-1.6.0/_build/../src/couch_replicator/test/07-use-checkpoints.t
>        (Wstat: 0 Tests: 16 Failed: 4)
> >  Failed tests:  9, 11, 13, 15
> > Result: FAIL
> >
> > deleted everything and rerunning, lets see if the same tests fail.
> >
> > </JamesM>
> >
> > On Apr 23, 2014, at 1:17, Robert Samuel Newson <rnewson@apache.org>
> wrote:
> >
> >> R14B04 should be fine (B02 is certainly not, though) and does have some
> important (but rare) bugfixes over B01. The strong recommendation for
> R14B01 comes from Cloudant. We run R14B01 and have for years, we trust it
> to work (and we trust it to fail in various known ways). I’m curious to
> know if the test issue vanishes on B01, though.
> >>
> >> B.
> >>
> >> On 23 Apr 2014, at 08:47, Mutton, James <jmutton@akamai.com> wrote:
> >>
> >>> I’m going back now and running against R14B01 (the usual
> recommendation) instead of R14B04.  Could be something odd between 01 and
> 04 and also this error was on OSX 10.9 not linux, so I’d stop short of
> saying that all of R14 is borked.
> >>>
> >>> </JamesM>
> >>>
> >>> On Apr 23, 2014, at 0:35, Dirkjan Ochtman <dirkjan@ochtman.nl> wrote:
> >>>
> >>>> Hi folks,
> >>>>
> >>>> What do we make of these?
> >>>>
> >>>> On Fri, Apr 18, 2014 at 11:20 AM, Garren Smith <garren@apache.org>
> wrote:
> >>>>> I get dist check passing. But when I run it, these two tests fail
> >>>>>
> >>>>> 21/87
> /tmp/couchdb/apache-couchdb-1.6.0/apache-couchdb-1.6.0/_build/../share/www/script/test/design_docs.js
> ... FAIL
> >>>>> 26/87
> /tmp/couchdb/apache-couchdb-1.6.0/apache-couchdb-1.6.0/_build/../share/www/script/test/etags_views.js
> … FAIL
> >>>>>
> >>>>> If I run them individually (make dev then ./test/javascript/run
> ./share/www/script/test/etags_views.js) sometimes they pass and other times
> they fail. I’m on Mac OSx 10.9.2 Erlang R16B03
> >>>>
> >>>> I think the fact that that you "get dist check passing" even though
> >>>> some tests fail is pretty worrying. But apparently either no one is
> >>>> reproducing these failures or no one is seeing them (since distcheck
> >>>> passes anyway)?
> >>>>
> >>>> On Sat, Apr 19, 2014 at 12:03 AM, Mutton, James <jmutton@akamai.com>
> wrote:
> >>>>> R14B04
> >>>>> Sigs: OK
> >>>>> Hashes: OK
> >>>>> ../test/etap/231-cors.t                          (Wstat: 0 Tests:
27
> Failed: 1)
> >>>>> Failed test:  27
> >>>>> Parse errors: Bad plan.  You planned 26 tests but ran 27.
> >>>>> Files=51, Tests=1213, 309 wallclock secs ( 0.46 usr  0.11 sys +
> 139.07 cusr 19.59 csys = 159.23 CPU)
> >>>>> Result: FAIL
> >>>>> Install/Run: OK
> >>>>> Verify: OK
> >>>>
> >>>> So this works on R15, R16, but not R14? Isn't this what we fixed
> since rc.2?
> >>>>
> >>>> Cheers,
> >>>>
> >>>> Dirkjan
> >>>
> >>
> >
>
>


-- 
Andy Wenk
Hamburg - Germany
RockIt!

http://www.couchdb-buch.de
http://www.pg-praxisbuch.de

GPG fingerprint: C044 8322 9E12 1483 4FEC 9452 B65D 6BE3 9ED3 9588

https://people.apache.org/keys/committer/andywenk.asc

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message