couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Shorin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1986) 04-replication-large-atts.t times out
Date Wed, 26 Feb 2014 13:45:21 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1986?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13912898#comment-13912898
] 

Alexander Shorin commented on COUCHDB-1986:
-------------------------------------------

[~benoitc] on master's HEAD (sorry, lost my note about actually commit, but it's not older
than 5 days ago) and with Nick's patch. Same picture I have for 1.6.x branch, so actually
it doesn't really matters.

Summarizing: set {{recbuf}} to a minimun 32768 to let the issue been solved. Currently it's
8192 by default. So factor is 4. But it's workaround.

[~nicknorth] yes, I noticed that mochiweb reads by 4096 chunks from socket while ibrowse send
8192 sized chunks. If you take a look on logs against different recbuf factor, you'll notice
the pattern how timings are changing over time. I left there only 1 replication worker to
produce quite solid picture.


> 04-replication-large-atts.t times out
> -------------------------------------
>
>                 Key: COUCHDB-1986
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1986
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Replication
>    Affects Versions: 1.5.0
>            Reporter: Jan Lehnardt
>
> 04-replication-large-atts.t gets stuck around 558, sometimes a little earlier or later,
but it times out eventually, regardless of the timeout. I tried doubling and such.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message