couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benoit Chesneau <>
Subject Re: splitting rcouch in multiple repo
Date Wed, 05 Feb 2014 17:28:28 GMT
On Wed, Feb 5, 2014 at 5:52 PM, Paul Davis <>wrote:

> > ok, make sense since i have also at some point moved it to src/couch (and
> > will be renamed to couch_core soon in rcouch).
> Why are you wanting to rename couch to couch_core? Erlang standard is
> to have "app/src/app_*.erl". Renaming everything to couch_core_*.erl
> would be a fairly massive change.

Well in theory you don't need to rename everything as couch_core_* . That's
more to have a proper naming for what is the core or not. couch by itself
could be the release point (or not). I am not sure it's really needed.

- benot

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message