couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benoit Chesneau (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1989) move src/couchjs-node in an `extra` repository
Date Sun, 05 Jan 2014 15:42:51 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1989?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13862572#comment-13862572
] 

Benoit Chesneau commented on COUCHDB-1989:
------------------------------------------

Well I do somehow. 

This change is supposed to be independent of any introduction of rebar later. The idea is
 to move most of the code that need to move before any change deeper change. But I can move
differently if there is a need for.

Anyway if you want it to be done at the same time, then we have many possibilities. I've launched
many threads (at least 2 on the ml) on this topic without much response before, so it's about
time. Here is a quick summary of what could be possible -  I probably miss the other one -
:

1. put it in its own repo and have onl main aps in the source code. The application will be
then imported before the build or the release (bin or source)
2. change the layout in src like yoiu said, having src/extra, src/?
3. Some are doing src/lib, src/external (for deps like mochiweb), src/...
4. my preferred lib/{couch_*}, extra/... external(or thirdparty)/... and the one I am actually
working on.
5. anything other.






> move src/couchjs-node in an `extra` repository
> ----------------------------------------------
>
>                 Key: COUCHDB-1989
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1989
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: Build System, JavaScript View Server
>            Reporter: Benoit Chesneau
>
> Since the build of couchjs-node is optional we should put it outside of the src/ folder
and move it to an `extra` folder (and the same for all extras). The reasoning behind is that
we should separate more clearly what is an addon from what is the core product.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message