couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <...@apache.org>
Subject Re: CouchDB Plugins - no_erlang_checksum error
Date Wed, 08 Jan 2014 14:47:40 GMT

On 08 Jan 2014, at 15:34 , Jan Lehnardt <jan@apache.org> wrote:

> 
> On 08 Jan 2014, at 15:00 , Andy Wenk <andy@nms.de> wrote:
> 
>> On 8 January 2014 13:48, Jan Lehnardt <jan@apache.org> wrote:
>> 
>>> 
>>> On 08 Jan 2014, at 00:23 , Andy Wenk <andy@nms.de> wrote:
>>> 
>>>> Hi,
>>>> 
>>>> I have watched and followed Jason's talk about CouchDB plugins at
>>> CouchConf
>>>> 2013. Jason, thanks for the awesome talk.
>>>> 
>>>> As far as I understood, Jason did all that against the 1.5.0 master
>>> branch.
>>>> But I could not get it working and received the following error:
>>>> 
>>>> [info] [<0.117.0>] 127.0.0.1 - - GET
>>>> /plugins/first/my_first_couchdb_plugin-0.0.1-R16B03-1.5.0.tar.gz 404
>>>> [error] [<0.107.0>] [couch_plugins] Can't find checksum for Erlang
>>> Version
>>>> 'R16B03'
>>>> [error] [<0.107.0>] Uncaught error in HTTP request: {error,
>>>>                                                   {badmatch,
>>>>                                                    {error,
>>>> 
>>> no_erlang_checksum}}}
>>>> [info] [<0.107.0>] Stacktrace: [{couch_plugins,install,1,
>>>>                                  [{file,"src/couch_plugins.erl"},
>>>>                                   {line,34}]},
>>>>                              {couch_plugins_httpd,handle_req,1,
>>>>                                  [{file,"src/couch_plugins_httpd.erl"},
>>>>                                   {line,31}]},
>>>>                              {couch_httpd,handle_request_int,5,
>>>> 
>>> [{file,"couch_httpd.erl"},{line,332}]},
>>>>                              {mochiweb_http,headers,5,
>>>> 
>>> [{file,"mochiweb_http.erl"},{line,94}]},
>>>>                              {proc_lib,init_p_do_apply,3,
>>>>                                  [{file,"proc_lib.erl"},{line,239}]}]
>>>> [info] [<0.107.0>] 127.0.0.1 - - POST /_plugins 500
>>>> [error] [<0.107.0>] httpd 500 error response:
>>>> {"error":"badmatch","reason":"{error,no_erlang_checksum}"}
>>>> 
>>>> Is this because I did not work against the 1867-feature-plugins branch
>>>> (actually it's called 1867-feature-plugins-jhs) like said in
>>>> my_first_couchdb_plugin/README or is that error caused by something
>>> else? I
>>>> recompiled the plugin to get another checksum and repeated everything but
>>>> still failing ...
>>> 
>>> master should be fine. Can you post your plugin specification somewhere?
>>> 
>> 
>> plugin.json right?
>> 
>> https://gist.github.com/andywenk/8317116
> 
> Yup, and does this match the CouchDB installation you are trying to install this into?
> 
> E.g. is it CouchDB 1.5.0 running on R16B02? :)

And also, how do you start the plugin installation?


> 
> Best
> Jan
> -- 
> 
>> 
>> Thanks!
>> 
>> Cheers
>> 
>> Andy
>> 
>> -- 
>> Andy Wenk
>> Hamburg - Germany
>> RockIt!
>> 
>> http://www.couchdb-buch.de
>> http://www.pg-praxisbuch.de
>> 
>> GPG fingerprint: C044 8322 9E12 1483 4FEC 9452 B65D 6BE3 9ED3 9588
>> 
>> https://people.apache.org/keys/committer/andywenk.asc


Mime
View raw message