couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emilien Kenler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1946) Trying to replicate NPM grinds to a halt after 40GB
Date Tue, 10 Dec 2013 07:44:09 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13844045#comment-13844045
] 

Emilien Kenler commented on COUCHDB-1946:
-----------------------------------------

Hi,

As I said, I was able to replicate the npm registry with only 1GB of memory on CouchDB 1.2.0.
Even if the replication works on CouchDB 1.5.0, it should work with a similar amount of memory.
I don't think that it's an Erlang related issue, because I use the same version of Erlang
for my tests.
I use the default configuration of CouchDB, so I think it's strange to have to change something
to make the replication work on 1.5.0 if it works without any change on 1.2.0.

I can provide access to my two test VM, and I can provide new VM if needed.

> Trying to replicate NPM grinds to a halt after 40GB
> ---------------------------------------------------
>
>                 Key: COUCHDB-1946
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1946
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Database Core
>            Reporter: Marc Trudel
>         Attachments: couch.log
>
>
> I have been able to replicate the Node.js NPM database until 40G or so, then I get this:
> https://gist.github.com/stelcheck/7723362
> I one case I have gotten a flat-out OOM error, but I didn't take a dump of the log output
at the time.
> CentOS6.4 with CouchDB 1.5 (also tried 1.3.1, but to no avail). Also tried to restart
replication from scratch - twice - bot cases stalling at 40GB.



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message