couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emilien Kenler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1946) Trying to replicate NPM grinds to a halt after 40GB
Date Tue, 03 Dec 2013 15:03:36 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13837773#comment-13837773
] 

Emilien Kenler commented on COUCHDB-1946:
-----------------------------------------

Hi,

I tried to do a npm replica too.

I set up a new VM with 1GB RAM on Debian Wheezy with CouchDB 1.2.0 from repository and Erlang
R15B01 (erts-5.9.1).
I create the replica by using the following command:
~curl -X POST http://127.0.0.1:5984/_replicate -d '{"source":"http://isaacs.iriscouch.com/registry/",
"target":"registry", "continuous":true, "create_target":true}' -H "Content-Type: application/json"~

In about 12h, I obtained a working replica (127GB).
Then I saw the Marc's problem, and noticed that npm is on CouchDB 1.5.0.
I decided to run a new replica on a new VM with the same configuration exept CouchDB in 1.5.0.

I followed the instructions in the documentation and on the wiki, and I installed the libmozjs185-cloudant{,-dev}
packages. http://wiki.apache.org/couchdb/Installing_on_Debian

I start the replication from my working CouchDB 1.2.0 server to the new CouchDB 1.5.0 server.
In few hours (about 36GB replicated), the replication stopped and it crashed (Out of memory
in syslog).

I upgraded my VM to 8GB of memory, but nothing changes.

The error logs are here: https://gist.github.com/MiLk/a1abd11aedb24c20c9d5



> Trying to replicate NPM grinds to a halt after 40GB
> ---------------------------------------------------
>
>                 Key: COUCHDB-1946
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1946
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Database Core
>            Reporter: Marc Trudel
>         Attachments: couch.log
>
>
> I have been able to replicate the Node.js NPM database until 40G or so, then I get this:
> https://gist.github.com/stelcheck/7723362
> I one case I have gotten a flat-out OOM error, but I didn't take a dump of the log output
at the time.
> CentOS6.4 with CouchDB 1.5 (also tried 1.3.1, but to no avail). Also tried to restart
replication from scratch - twice - bot cases stalling at 40GB.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message