couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Trudel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1946) Trying to replicate NPM grinds to a halt after 40GB
Date Tue, 03 Dec 2013 01:54:37 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13837229#comment-13837229
] 

Marc Trudel commented on COUCHDB-1946:
--------------------------------------

curl $COUCH/registry | python -mjson.tool
```javascript
{
    "committed_update_seq": 51009,
    "compact_running": false,
    "data_size": 39439860666,
    "db_name": "registry",
    "disk_format_version": 6,
    "disk_size": 47768499249,
    "doc_count": 38858,
    "doc_del_count": 3886,
    "instance_start_time": "1386033114907901",
    "purge_seq": 0,
    "update_seq": 51009
}
```

Logs are here attached. This is a log from startup to crash, so there is certainly a bit of
noise in there.

Extra note: as download goes, until I hit the 40G mark I replicate at 10Mbps. Then it goes
down slowly until it hits a bit below 200Kbps

I am downloading a .couch file copy from someone who already has a server up and running.
Will give a try to this too, and will report any findings...

> Trying to replicate NPM grinds to a halt after 40GB
> ---------------------------------------------------
>
>                 Key: COUCHDB-1946
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1946
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Database Core
>            Reporter: Marc Trudel
>         Attachments: couch.log
>
>
> I have been able to replicate the Node.js NPM database until 40G or so, then I get this:
> https://gist.github.com/stelcheck/7723362
> I one case I have gotten a flat-out OOM error, but I didn't take a dump of the log output
at the time.
> CentOS6.4 with CouchDB 1.5 (also tried 1.3.1, but to no avail). Also tried to restart
replication from scratch - twice - bot cases stalling at 40GB.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message