couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Kocoloski (JIRA)" <>
Subject [jira] [Commented] (COUCHDB-1946) Trying to replicate NPM grinds to a halt after 40GB
Date Fri, 27 Dec 2013 01:08:50 GMT


Adam Kocoloski commented on COUCHDB-1946:

Hi [~indexzero], there are absolutely material differences for local vs. remote replications
-- that's one axis I've been meaning to explore as soon as I have a chance to re-engage on
this ticket.  For example, I've not seen this happen on a replication to Cloudant (which has
no real notion of a "local" replication).

The other thing I'd love to see happen is a narrowing down of the list of affected versions;
1.2.0..1.5.0 is an awfully large changeset to bisect.

> Trying to replicate NPM grinds to a halt after 40GB
> ---------------------------------------------------
>                 Key: COUCHDB-1946
>                 URL:
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Database Core
>            Reporter: Marc Trudel
>         Attachments: couch.log
> I have been able to replicate the Node.js NPM database until 40G or so, then I get this:
> I one case I have gotten a flat-out OOM error, but I didn't take a dump of the log output
at the time.
> CentOS6.4 with CouchDB 1.5 (also tried 1.3.1, but to no avail). Also tried to restart
replication from scratch - twice - bot cases stalling at 40GB.

This message was sent by Atlassian JIRA

View raw message