couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charlie Robbins (JIRA)" <>
Subject [jira] [Commented] (COUCHDB-1946) Trying to replicate NPM grinds to a halt after 40GB
Date Fri, 27 Dec 2013 00:51:51 GMT


Charlie Robbins commented on COUCHDB-1946:

[~janl] Some more data about this:

* Replication got stuck at update_seq 861259 from the public npm registry
* Replacing the registry with a new .couch file via rsync solved the replication problem
* We had another local replication of the registry running, and against the new .couch file
local replication ran just fine past 861259

Any material differences / optimizations for local vs. remote replications?

> Trying to replicate NPM grinds to a halt after 40GB
> ---------------------------------------------------
>                 Key: COUCHDB-1946
>                 URL:
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Database Core
>            Reporter: Marc Trudel
>         Attachments: couch.log
> I have been able to replicate the Node.js NPM database until 40G or so, then I get this:
> I one case I have gotten a flat-out OOM error, but I didn't take a dump of the log output
at the time.
> CentOS6.4 with CouchDB 1.5 (also tried 1.3.1, but to no avail). Also tried to restart
replication from scratch - twice - bot cases stalling at 40GB.

This message was sent by Atlassian JIRA

View raw message