couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charlie Robbins (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1946) Trying to replicate NPM grinds to a halt after 40GB
Date Thu, 26 Dec 2013 21:49:51 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13857105#comment-13857105
] 

Charlie Robbins commented on COUCHDB-1946:
------------------------------------------

Was able to reproduce this in a similar, but distinctly different use-case. The replication
of the registry for one of our unused private replicas was not restarted for a couple of weeks.
This led to the a disk_size difference between the replica and the public npm registry of
>40GB. 

After restarting the replication we are now seeing this same behavior. Since these registries
were up to date when this issue was opened they were already past the document that Dave mentioned.
Looks to be a particular class of document(s) that causes this, not just a single document.

Dave: is there a way to figure out which document(s) could be causing this?

> Trying to replicate NPM grinds to a halt after 40GB
> ---------------------------------------------------
>
>                 Key: COUCHDB-1946
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1946
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Database Core
>            Reporter: Marc Trudel
>         Attachments: couch.log
>
>
> I have been able to replicate the Node.js NPM database until 40G or so, then I get this:
> https://gist.github.com/stelcheck/7723362
> I one case I have gotten a flat-out OOM error, but I didn't take a dump of the log output
at the time.
> CentOS6.4 with CouchDB 1.5 (also tried 1.3.1, but to no avail). Also tried to restart
replication from scratch - twice - bot cases stalling at 40GB.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message