couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Shorin (JIRA)" <>
Subject [jira] [Commented] (COUCHDB-1902) Success (201) response from Couchdb and document not created
Date Wed, 02 Oct 2013 21:06:42 GMT


Alexander Shorin commented on COUCHDB-1902:

[~rnewson], [already done|]
with a notice and the big red warning.

> Success (201) response from Couchdb and document not created
> ------------------------------------------------------------
>                 Key: COUCHDB-1902
>                 URL:
>             Project: CouchDB
>          Issue Type: Bug
>          Components: HTTP Interface
>            Reporter: Atif Rasheed
> We are using Tangerine for early grade assessments which basically is a couchapp. One
of our field engr reported that he was doing assessments and he had saved almost 9 results
when all of a sudden tablet went off (probably due to batter issue). He powered it up again
and after login to Tangerine he realized that all those saved results are gone. 
> We took logs and database from Tablet to PC for further analysis. We realized that it's
actually true as we can see those attempts in couch.log and we can also see successful HTTP
PUT requests as well on same _id's. Now we took that data from couch.log and tried to push
it manually (using Restful client) to couchdb; and it worked. Now we are not sure what went
wrong when tangerine pushed it to couchdb. Steps we followed and relevant outputs are pasted
below for your reference. Will appreciate if someone help us out here.
> 0) Stage 0:
> We looked into couch.logs and found a successful PUT against a particular assessment
result which is not available or visible in tangerine application.
> 1) Stage 1:
> Tried to get the same document by id and the couchapp return not_found
> 2) Stage 2:
> Then we manually copied last revision from that log file And posted/pushed manually via
REST Client to tangerine db (couchdb) and it was successful.
> Please note that the "_rev" at this stage is 34 because we hard-coded it in data file
while sending through REST API. Obviously, if we remove that line from JSON, The _rev would
be 1.

This message was sent by Atlassian JIRA

View raw message