couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Lehnardt (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (COUCHDB-1896) SSL / 1.4.0 / Erlang R16B02 in a kerfuffle
Date Wed, 25 Sep 2013 16:38:04 GMT

     [ https://issues.apache.org/jira/browse/COUCHDB-1896?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jan Lehnardt updated COUCHDB-1896:
----------------------------------

    Description: 
Just a quick reminder for myself, in lieu of a proper bug report:

[18:28:07] <jdhorner>	 Oh well. I couldn't figure it out, but removing 1.4 and reinstalling
1.3.1 allows https again. *shrug*
[18:28:25] <+jan____>	 ugh not good. do you have a test case we can use to reproduce?
[18:33:19] <jdhorner>	 Sure. Install all of the erlang dependencies @ version 16B2,
then do a default couchdb configure and install, and then try and get SSL working. :D
[18:33:31] <jdhorner>	 I think it has something to do with Mochiweb in the current 16B2
release.
[18:33:55] <+jan____>	 oh interesting
[18:33:59] <jdhorner>	 It just crashes over and over, even if you're not actively trying
to access https://127.0.0.1:6984/
[18:36:47] <jdhorner>	 and to be more specific, it's the R16B02 packages: erlang-base-hipe;
erlang-dev; erlang-nox; erlang-eunit  on an Ubuntu 13.04 machine, using the repositories directly
from the "erlang-solutions.com/debian raring contrib" repo


  was:
Just a quick reminder for myself, in lieu of a proper bug report:

[18:28:07] <jdhorner>	 Oh well. I couldn't figure it out, but removing 1.4 and reinstalling
1.3.1 allows https again. *shrug*
[18:28:25] <+jan____>	 ugh not good. do you have a test case we can use to reproduce?
[18:33:19] <jdhorner>	 Sure. Install all of the erlang dependencies @ version 16B2,
then do a default couchdb configure and install, and then try and get SSL working. :D
[18:33:31] <jdhorner>	 I think it has something to do with Mochiweb in the current 16B2
release.
[18:33:55] <+jan____>	 oh interesting
[18:33:59] <jdhorner>	 It just crashes over and over, even if you're not actively trying
to access https://127.0.0.1:6984/


    
> SSL / 1.4.0 / Erlang R16B02 in a kerfuffle
> ------------------------------------------
>
>                 Key: COUCHDB-1896
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1896
>             Project: CouchDB
>          Issue Type: New Feature
>          Components: HTTP Interface
>    Affects Versions: 1.4.0
>            Reporter: Jan Lehnardt
>             Fix For: 1.4.1, 1.5.0
>
>
> Just a quick reminder for myself, in lieu of a proper bug report:
> [18:28:07] <jdhorner>	 Oh well. I couldn't figure it out, but removing 1.4 and
reinstalling 1.3.1 allows https again. *shrug*
> [18:28:25] <+jan____>	 ugh not good. do you have a test case we can use to reproduce?
> [18:33:19] <jdhorner>	 Sure. Install all of the erlang dependencies @ version 16B2,
then do a default couchdb configure and install, and then try and get SSL working. :D
> [18:33:31] <jdhorner>	 I think it has something to do with Mochiweb in the current
16B2 release.
> [18:33:55] <+jan____>	 oh interesting
> [18:33:59] <jdhorner>	 It just crashes over and over, even if you're not actively
trying to access https://127.0.0.1:6984/
> [18:36:47] <jdhorner>	 and to be more specific, it's the R16B02 packages: erlang-base-hipe;
erlang-dev; erlang-nox; erlang-eunit  on an Ubuntu 13.04 machine, using the repositories directly
from the "erlang-solutions.com/debian raring contrib" repo

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message