couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Lehnardt (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1711) 140-attachment-comp fails on R15B02 and later
Date Sun, 17 Mar 2013 23:07:14 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1711?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13604784#comment-13604784
] 

Jan Lehnardt commented on COUCHDB-1711:
---------------------------------------

I tried a bisect from further back and now got pointed at:


> git show 48928ae3fdc4dfbfe65351aa9b93cd2086ef5b15
commit 48928ae3fdc4dfbfe65351aa9b93cd2086ef5b15
Author: Bob Dionne <bitdiddle@apache.org>
Date:   Tue Oct 23 20:01:32 2012 -0400

    Upgrade get_crlf funs to use binary BIF


but I also thing this is a false negative, this might point to an intermittent error, but
I don’t quite understand what the cause could be. If anyone could have a look as eel, that’d
be greatly appreciated!

                
> 140-attachment-comp fails on R15B02 and later
> ---------------------------------------------
>
>                 Key: COUCHDB-1711
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1711
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Test Suite
>    Affects Versions: 1.3
>            Reporter: Jan Lehnardt
>            Assignee: Jan Lehnardt
>            Priority: Blocker
>
> I'm on Mac OS X 10.8.2 and 10.7.5 1.3.x and master.
> I'm running the following:
> $ git clean -fdx
> $ ./bootstrap
> $ ./configure
> $ make
> $ test/etap/run test/etap/140*.t
> The tests fail with:
> est/etap/140-attachment-comp.t (Wstat: 0 Tests: 76 Failed: 0)
> Parse errors: Bad plan.  You planned 85 tests but ran 76.
> The function tha fails is:
> {noformat}
> test_create_already_compressed_att_with_invalid_content_encoding(
>     DocUri, AttName, AttData, Encoding) ->
>     {ok, Code, _Headers, _Body} = test_util:request(
>         DocUri ++ "/" ++ AttName,
>         [{"Content-Encoding", Encoding}, {"Content-Type", "text/plain"}],
>         put,
>         AttData),
>     etap:is(
>         Code,
>         415,
>         "Couldn't create an already compressed attachment using the "
>         "unsupported encoding '" ++ Encoding ++ "'"
>     ),
>     ok.
> {noformat}
> It is invoked twice, once with "deflate" as Encoding and once with "compress". The compress
one fails.
> I skimmed the Erlang R15B02 release notes, but couldn't find any hints. Any help appreciated.
> I consider this a blocker for 1.3.0.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message