couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Lehnardt (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1711) 140-attachment-comp fails on R15B02 and later
Date Sun, 17 Mar 2013 18:51:14 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1711?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13604714#comment-13604714
] 

Jan Lehnardt commented on COUCHDB-1711:
---------------------------------------

not that it makes too much sense, but two runs of git bisect revealed:

I found from CI what the last version was that did  work:

(on master)
{noformat}
git bisect start
git bisect bad
git bisect good eb7d91f
git bisect run ../run.sh

> cat ../run.sh 
#!/bin/sh
git clean -fdx
./bootstrap
./configure --disable-docs
make -j4 dev
./test/etap/run -v test/etap/140*.t
{noformat}


Points to 

{noformat}
bbd93f77baa4bfe1022b4fb9c9a66bdcaf9e17db is the first bad commit
commit bbd93f77baa4bfe1022b4fb9c9a66bdcaf9e17db
Author: Jan Lehnardt <jan@apache.org>
Date:   Wed Feb 20 16:49:31 2013 +0100

    document number encoding

{noformat}

which is a pure .rst file change. so that can’t be it. So, huh.
                
> 140-attachment-comp fails on R15B02 and later
> ---------------------------------------------
>
>                 Key: COUCHDB-1711
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1711
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Test Suite
>    Affects Versions: 1.3
>            Reporter: Jan Lehnardt
>            Assignee: Jan Lehnardt
>            Priority: Blocker
>
> I'm on Mac OS X 10.8.2 and 10.7.5 1.3.x and master.
> I'm running the following:
> $ git clean -fdx
> $ ./bootstrap
> $ ./configure
> $ make
> $ test/etap/run test/etap/140*.t
> The tests fail with:
> est/etap/140-attachment-comp.t (Wstat: 0 Tests: 76 Failed: 0)
> Parse errors: Bad plan.  You planned 85 tests but ran 76.
> The function tha fails is:
> {noformat}
> test_create_already_compressed_att_with_invalid_content_encoding(
>     DocUri, AttName, AttData, Encoding) ->
>     {ok, Code, _Headers, _Body} = test_util:request(
>         DocUri ++ "/" ++ AttName,
>         [{"Content-Encoding", Encoding}, {"Content-Type", "text/plain"}],
>         put,
>         AttData),
>     etap:is(
>         Code,
>         415,
>         "Couldn't create an already compressed attachment using the "
>         "unsupported encoding '" ++ Encoding ++ "'"
>     ),
>     ok.
> {noformat}
> It is invoked twice, once with "deflate" as Encoding and once with "compress". The compress
one fails.
> I skimmed the Erlang R15B02 release notes, but couldn't find any hints. Any help appreciated.
> I consider this a blocker for 1.3.0.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message