couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Ramage (JIRA)" <>
Subject [jira] [Commented] (COUCHDB-1633) ./bootstrap error -> "Have you installed GNU Autoconf Archive?"
Date Wed, 13 Mar 2013 17:18:14 GMT


Ryan Ramage commented on COUCHDB-1633:

Ok, I was using Xcode 3.6, which was the highest I could get got for OSX 10.6(.8). I could
not get ./bootstrap to work. I paid the apple tax, and upgraded to mountain lion and xcode
4.6. After signing the xcode licenses, everything worked flawlessly. I dont want to exclude
people from using an older osx, but unfortunately I cant help test it anymore :)
> ./bootstrap error -> "Have you installed GNU Autoconf Archive?"
> ---------------------------------------------------------------
>                 Key: COUCHDB-1633
>                 URL:
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Build System
>            Reporter: Benoit Chesneau
>            Assignee: Dave Cottlehuber
>            Priority: Blocker
>             Fix For: 1.3
>         Attachments: locate.txt
> Something new with the build of couchdb I didn't have before. Now when launching bootstrap
for the first time I get the following error:
>     $ make
>     CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /Users/benoitc/work/couchdb/build-aux/missing
--run aclocal-1.12 -I m4
>      cd . && /bin/sh /Users/benoitc/work/couchdb/build-aux/missing --run automake-1.12
>     CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /Users/benoitc/work/couchdb/build-aux/missing
--run autoconf
> error: possibly undefined macro: AC_DEFINE
>           If this token and others are legitimate, please use m4_pattern_allow.
>           See the Autoconf documentation.
> error: possibly undefined macro: AC_MSG_WARN
>     make: *** [configure] Error 1
>     enlil:couchdb benoitc$ ./bootstrap 
>     Unable to find the `ax_check_icu.m4' file.
>     Have you installed GNU Autoconf Archive?
> I solved it on ubuntu by installing autcoconf-archive. But I have no idea how to do the
same thing on macosx yet. Also it should be documented so far.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message