couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendall Cada <wenda...@83864.com>
Subject 1.3.0 Test Suite Failures
Date Mon, 11 Mar 2013 21:14:35 GMT
While testing 1.3.0-rc.1 I ran into some issues with the test suite.

On Fedora 18:

I get intermittent failures, or the test suite just stalls out 
indefinitely. Once I get a complete run, all tests succeed, except 
rev_stemming. However, this only fails when run with the entire test 
suite. If I run ./test/javascript/run test_stemming after the rest of 
the tests are complete, it succeeds without issue.

On Centos 6:

Test hangs on attachment_ranges for several minutes, then finally segfaults.
./test/javascript/run: line 75: 17554 Segmentation fault $COUCHJS -H -u 
$COUCH_URI_FILE $SCRIPT_DIR/json2.js $SCRIPT_DIR/sha1.js 
$SCRIPT_DIR/oauth.js $SCRIPT_DIR/couch.js 
$SCRIPT_DIR/couch_test_runner.js $SCRIPT_DIR/couch_tests.js $TEST_SRC 
$JS_TEST_DIR/couch_http.js $JS_TEST_DIR/cli_runner.js

I manually ran some other tests, including test_stemming, they appear to 
succeed, but test suite bails after the segfault, so can't continue.

Installed spidermonkey is 1.85. The installed package is basically 
identical to the one Cloudant maintains.

Wendall

Mime
View raw message