couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pierre Voisin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1655) CentOS + CouchDB 1.2.1 - Adding documents to _users fails with a "OS Process Error" error
Date Mon, 28 Jan 2013 14:11:13 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1655?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13564293#comment-13564293
] 

Pierre Voisin commented on COUCHDB-1655:
----------------------------------------

Hello, thanks for your answer!

Indeed, CentOS doesn't ship with SpiderMonkey 1.8.5 but I've installed it even before I installed
CouchDB.

Here's what I'm getting by running "locate 185":

{code}$ sudo locate 185
/usr/bin/db_dump185
/usr/local/lib/libmozjs185-1.0.a
/usr/local/lib/libmozjs185.so
/usr/local/lib/libmozjs185.so.1.0
/usr/local/lib/libmozjs185.so.1.0.0
/usr/local/lib/pkgconfig/mozjs185.pc
 ...{code}

I've then tried to set up a environment variable like this in /etc/environment:

{code}export LD_LIBRARY_PATH=/usr/local/lib{code}

I then sourced it to check if it's correctly exposed and restarted couchdb but the results
are unfortunately the same... Does couchdb, when starting, source /etc/environment in any
manner?
                
> CentOS + CouchDB 1.2.1 - Adding documents to _users fails with a "OS Process Error" error
> -----------------------------------------------------------------------------------------
>
>                 Key: COUCHDB-1655
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1655
>             Project: CouchDB
>          Issue Type: Bug
>            Reporter: Pierre Voisin
>         Attachments: trace.txt
>
>
> I've installed CouchDB 1.2.1 on my CentOS 6.2, initially following this guide [http://www.thegeekstuff.com/2012/06/install-couch-db/]
but then relying on packages bundled with CentOS (except for CouchDB itself that I want to
be 1.2.1) and it seemed to be working nicely until I tried to create a user.
> Basically, I'm getting a "OS Process Error" exception with that trace that I'm attaching
to the issue right after:
> [Mon, 28 Jan 2013 02:06:03 GMT] [error] [<0.331.0>] OS Process Error <0.359.0>
:: {os_process_error,
>                                                    {exit_status,134}}
> [Mon, 28 Jan 2013 02:06:03 GMT] [error] [<0.331.0>] ** Generic server couch_query_servers
terminating
> ** Last message in was {get_proc,{doc,<<"_design/_auth">>,
> ...yadayadayada...
>                                                {<<"_design/_auth">>,
>                                                 <<"1-a8cfb993654bcc635f126724d39eb930">>}},
>                                               infinity]}}
> [Mon, 28 Jan 2013 02:06:03 GMT] [info] [<0.304.0>] 70.30.198.177 - - PUT /_users/org.couchdb.user:pvoisin
500
> I'm a bit scared about reading such a trace and I'm absolutely not at ease enough to
decrypt that message.
> The thing is I can add users successfully with the CentOS couchdb package (which is a
1.0.3).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message