couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Smith (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1643) Switch to V8
Date Sat, 26 Jan 2013 07:39:14 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1643?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13563398#comment-13563398
] 

Jason Smith commented on COUCHDB-1643:
--------------------------------------

A few more (starting to overlap a bit but IMO that is fine):

5. require() is not possible. There is no access to any functions/objects/APIs except what
is given. In fact, require() is to load from the ddoc, not Node.js.
6. Nothing from the "couch" side of the call stack is visible, e.g. `(new Error).stack` is
unhelpful
7. DOS is not possible, e.g. while(true) {}

                
> Switch to V8
> ------------
>
>                 Key: COUCHDB-1643
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1643
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: JavaScript View Server
>            Reporter: Jan Lehnardt
>
> I’d like to propose that we switch to the V8 JavaScript engine to mitigate the various
issues we have with SpiderMonkey.
> This ticket acts as the meta-issue where we can discuss whether we all agree and what
needs doing. individual tasks then can get their own tickets.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message