couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miles Fidelman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1640) build instructions broken for Debian
Date Mon, 14 Jan 2013 05:48:13 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1640?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13552446#comment-13552446
] 

Miles Fidelman commented on COUCHDB-1640:
-----------------------------------------

Well folks, I may have been to clever for my own good.  Turns out the build instructions are
NOT broken.

1. I just built a new, clean, Debian Squeeze virtual machine, and downloaded the tarball for
CouchDB 1.2.1.  Then I followed the instructions from the INSTALL.Unix file, exactly, using
packages from the Debian stable archive to satisfy all dependencies.  Nothing built from source
except CouchDB.  No flags in ./configure.  Everything worked, including the developer tests.
 

2. At first, I thought that I'd been waylaid by following the build instructions on the web
site - following links from couch.apache.org -> quicklinks -> wiki.apache.org/couchdb/
-> wiki.apache.org/couchdb/Installation, which is:
- out of date (talks about releases 1.0 and 1.1, not 1.2 or 1.2.1)
- omits Debian from it's list of build-system-specific instructions, but...
- has a link to https://git-wip-us.apache.org/repos/asf/couchdb/repo?p=couchdb.git;a=blob;f=INSTALL.Unix;hb=master,
which is the latest version of the INSTALL.Unix instructions - WHICH DIFFERS SIGNIFICANTLY
FROM THE INSTRUCTIONS PACKAGED WITH 1.2.1, and to confuse matters more, includes the line:
""For up to date instructions, please see: http://wiki.apache.org/couchdb/Installing_on_Debian"
-- which are the instructions that I followed yesterday, with the exception of pulling the
absolutely latest release of Erlang, and building all of it's optional dependencies (some
of which are not required to support Couch).  
- Today, I followed the instructions exactly (earlier release of Erlang, no optional dependencies),
and everything worked - with one exception - the instructions say to start Couch with /etc/init.d/couchdb
start - but the build leaves the file in /usr/local/etc/init.d (the instructions in the tarball
address this)
- so, either there was something on my system that made things go South, or there's an incompatability
with the newer Erlang - but it was not a problem with needing to build spidermonkey - the
Debian stable package of libmozjs-dev is sufficient

So... perhaps the first message, in the immortal words of Emily Litella, is "never mind."
 Beyond that, perhaps there is a bit of confusion surrounding two many versions of the build
instructions floating around, and too many paths through the web site.  The instructions in
the tarball are correct, and should be referenced everywhere.

Sorry for the inconvenience.  Sigh....





                
> build instructions broken for Debian
> ------------------------------------
>
>                 Key: COUCHDB-1640
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1640
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Build System
>            Reporter: Miles Fidelman
>            Assignee: Dave Cottlehuber
>
> The instructions for building 1.2.1, from source, on Debian Stable (Squeeze) are completely
broken - both the INSTALL.Unix file in the distribution, and the wiki page at http://wiki.apache.org/couchdb/Installing_on_Debian
> For one, the version of spidermonkey (libmozjs) is older than the minimum required for
Couch 1.2.1.
> For two, even after installing the latest spidermonkey from upstream, I can't get more
than half the developer tests to complete after an install.  I expect it has to do with path
issues and the proper invocation of ./configure - but I can't figure out what the magic incantation
is.
> I kind of wonder if anybody has actually tried a full install on Debian Stable.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message