couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Randall Leeds (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1572) Remove support for spidermonkey versions < 1.8.5
Date Thu, 25 Oct 2012 21:59:12 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1572?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13484522#comment-13484522
] 

Randall Leeds commented on COUCHDB-1572:
----------------------------------------

Do it! It's not a breaking change. It's not the kind of thing that one can be unpleasantly
surprised about. It's not as though you can build a new couchdb version without the dependency,
so you can't ship a new couchdb in production, issue your equivalent of "/etc/init.d/couchdb
restart" and be surprised to find that it doesn't run.

It may cause a few packagers some pain, but really, would it now? I challenge you to identify
one distro that would ship a 1.3 (or 1.4) couchdb in their repo which doesn't already have
a js1.8.5 package in same repo/series.
                
> Remove support for spidermonkey versions < 1.8.5
> ------------------------------------------------
>
>                 Key: COUCHDB-1572
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1572
>             Project: CouchDB
>          Issue Type: Improvement
>            Reporter: Robert Newson
>             Fix For: 1.4
>
>
> Simplify build system and provide a consistent Javascript environment by ditching spidermonkey
versions below 1.8.5

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message