couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Cottlehuber <d...@muse.net.nz>
Subject Re: dependancy tracking
Date Thu, 21 Jun 2012 12:00:55 GMT
On 21 June 2012 09:40, Dirkjan Ochtman <dirkjan@ochtman.nl> wrote:
> On Thu, Jun 21, 2012 at 9:23 AM, Dave Cottlehuber <dave@muse.net.nz> wrote:
>> I think we're only talking about OTP apps (snappy, ejson/jiffy, mochiweb) here.
>> Would you want those as separate packages?
>
> Yes, preferably. To give an example, if for some reason there was a
> security vulnerability in snappy, it would be great if the distro
> doesn't have to go around checking which packages might package their
> own snappy, and instead can just update the canonical snappy. This
> goes for the other stuff, too. I should really have helped out more on
> making it easier to build against system versions of these apps, but
> that requires some autotools and/or Erlang foo that I really don't
> have.
>
> I filed https://issues.apache.org/jira/browse/COUCHDB-1458 for snappy
> two months ago.
>
> Cheers,
>
> Dirkjan

Aah yes I remember that, maybe Filipe can comment. Currently snappy is
built with a mix of CouchDB/Erlang NIF layer & the google code in one chunk,
it's not actually two separate shared objects  / DLLs. Could it still use the
system version in this case? I would guess not?

A+
Dave

Mime
View raw message