couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Kögl <>
Subject Re: Update Conflict for PUT/DELETE in _replicator
Date Mon, 12 Mar 2012 13:09:23 GMT
On Mon, Mar 12, 2012 at 2:01 PM, Jason Smith <> wrote:
> On Mon, Mar 12, 2012 at 12:57 PM, Stefan Kögl <> wrote:
>> In the meantime I tried copying the _replicator database to another
>> instance, where I could delete the entry without problems. However it
>> still doesn't work on the initial instance. If one of the committers
>> is interested, I could organize either remote access via HTTP, or
>> shell access to the machine it is running on.
> Hm, if you copied the _replicator.couch file from the 1.2.x prerelease
> to version 1.1 then it will not support the newer file format.
> You could replicate to it, or since replication docs have no
> attachments, just query _all_docs, massage that into a _bulk_docs, and
> post it to the other couch.

That's not the problem. I copied the database to another 1.2.x
CouchDB, which could read and update it correctly.
The problem is the original 1.2.x instance (both are on the current
1.2.x branch, btw) where I created the entry but can not update /
delete it anymore.

-- Stefan

View raw message