couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Volker Mische <volker.mis...@gmail.com>
Subject Re: Cannot build geocouch in cygwin, any ideas?
Date Wed, 28 Mar 2012 14:05:15 GMT
Hi,

I never tried it myself to build GeoCouch on Windows. But it seems
possible, as Couchbase did it.

On 03/28/2012 03:54 PM, JohnRodey wrote:
> So I've followed the instructions in the README for geocouch.  I've set the
> COUCH_SRC env variable to point to my <couchdb>/src/couchdb directory. 
> However I still get the following error:
> 
> $ make
> Recompile: src/vtree/vtree_bulk
> src/vtree/vtree_bulk.erl:15: can't find include file "couch_db.hrl"
> Makefile:7: recipe for target `compile' failed
> make: *** [compile] Error 1
> 
> Any help or ideas are greatly appreciated!  I assume it just cant find my
> couchdb source.  Ive echoed COUCH_SRC in the makefile and it looks correct.

Are you sure the couch_db.hrl is in the path you've specified with
COUCH_SRC?

> Is there a windows binary somewhere that I could download, to avoid building
> for now?

I don't know any.

> Is there a users forum for couchdb/geocouch?  If so, could you provide me
> with a link?  I didn't see anything in the nabble search or via google.

This mailing list (though I'd suggest the user, rather then the dev
list) is the right place.

Cheers,
  Volker

Mime
View raw message