couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Dionne <dio...@dionne-associates.com>
Subject Re: [VOTE] Apache CouchDB 1.2.0 release, second round
Date Thu, 23 Feb 2012 03:06:16 GMT
perhaps, oddly if I try it without running make distcheck first I get a different error:

Segmentation fault: 11

dependencies are fun
On Feb 22, 2012, at 9:51 PM, Paul Davis wrote:

> More than likely this is the SSL issue that Erlang has had issues
> with. Perhaps its time that I go in and see if I can't patch Erlang to
> use the newer OS X functions. Filipe had more details but IIRC the fix
> was basically to compile your own SSL and get Erlang to link against
> that.
> 
> On Wed, Feb 22, 2012 at 8:07 PM, Bob Dionne
> <dionne@dionne-associates.com> wrote:
>> I've been doing that all along, master branch, 1.0.x, any source build is fine. I
saw these occasionally before on the Mackbook Pro, this is the first one I've seen on the
MBA
>> 
>> It is odd that I'm only seeing it on this build, the only diff being I hardly ever
run make distcheck. I'll try it without running that.
>> 
>> 
>> On Feb 22, 2012, at 8:02 PM, Noah Slater wrote:
>> 
>>> Could you try again a few times maybe, try testing the source directly from
>>> your checkout?
>>> 
>>> On Thu, Feb 23, 2012 at 12:26 AM, Bob Dionne
>>> <dionne@dionne-associates.com>wrote:
>>> 
>>>> I've seen this page before Noah, and something like these Bus errors. I
>>>> think it might be the use of R15B
>>>> 
>>>> What's odd is that I don't have any problems withe the 1.2 branch, or any
>>>> branch for that matter
>>>> 
>>>> On Feb 22, 2012, at 6:55 PM, Noah Slater wrote:
>>>> 
>>>>> Can you try this and report back please:
>>>>> 
>>>>> 
>>>> http://wiki.apache.org/couchdb/Troubleshooting#Segmentation_faults_and_bus_errors
>>>>> 
>>>>> On Wed, Feb 22, 2012 at 11:51 PM, Bob Dionne
>>>>> <dionne@dionne-associates.com>wrote:
>>>>> 
>>>>>> make distcheck ran ok
>>>>>> 
>>>>>> server keeps crashing with:
>>>>>> 
>>>>>> Bus error: 10
>>>>>> 
>>>>>> On Feb 22, 2012, at 6:29 PM, Noah Slater wrote:
>>>>>> 
>>>>>>> I might add that I got a segfault on the first try with the test
suite,
>>>>>> but
>>>>>>> was unable to reproduce it with two further runs. I would appreciate
>>>> some
>>>>>>> feedback on this to assure me that it's nothing to worry about.
>>>>>> 
>>>>>> 
>>>> 
>>>> 
>> 


Mime
View raw message