couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dirkjan Ochtman (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1399) Rename _rev to _mvcc or _lock
Date Fri, 03 Feb 2012 13:49:54 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13199705#comment-13199705
] 

Dirkjan Ochtman commented on COUCHDB-1399:
------------------------------------------

This seems like exceedingly limited benefit for a big break in compatibility. I'd suggest
the solution should be better docs, instead.
                
> Rename _rev to _mvcc or _lock
> -----------------------------
>
>                 Key: COUCHDB-1399
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1399
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: Database Core
>    Affects Versions: 2.0
>            Reporter: Paul Joseph Davis
>             Fix For: 2.0
>
>
> We should rename the "revisions" to "lock" or "token" or some other suitably opaque term
so we stop getting people asking questions about treating them as revisions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message