couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Davis <paul.joseph.da...@gmail.com>
Subject Re: git commit: Fix SpiderMonkey version detection
Date Sun, 22 Jan 2012 20:57:30 GMT
Dave confirmed. Backported to 1.1.x and 1.2.x. Sorry for the dumb
mistake on that one.

On Sun, Jan 22, 2012 at 2:47 PM, Paul Davis <paul.joseph.davis@gmail.com> wrote:
> Dave pasted me part of his. I realized that I moved the header check
> above the spot where we assign the JS_CPPFLAGS which was dumb of me.
> Pushed a fix in 572b561adbf852e08c7397519070f299d0b401e4 to master.
> Soon as I have confirmation it's correct I'll backport to 1.2.x and
> 1.1.x
>
> On Sun, Jan 22, 2012 at 2:38 PM, Paul Davis <paul.joseph.davis@gmail.com> wrote:
>> Most odd since I only added three directories to search for.
>>
>> Can you all post me a config.log so I can see the compiler options being used?
>>
>> On Sun, Jan 22, 2012 at 1:56 PM, Dave Cottlehuber <dave@muse.net.nz> wrote:
>>> On 22 January 2012 19:15, Filipe David Manana <fdmanana@apache.org> wrote:
>>>> Paul, after this change I'm no longer able to build master (haven't
>>>> tried other branches however).
>>>
>>> Ditto.
>>>
>>>> configure can't find js/jsapi.h, this is because my jsapi.h doesn't
>>>> live inside a js directory.
>>>>
>>>> Ubuntu 10.10
>>>> jsapi.h full path: /usr/include/xulrunner-1.9.2.24/jsapi.h
>>>>
>>>> flags passed to configure:
>>>>
>>>> configure --with-js-include=/usr/include/xulrunner-1.9.2.24
>>>> --with-js-lib=/usr/lib/xulrunner-1.9.2.24
>>>
>>> Windows::
>>> /relax/js-1.8.5/js/src/dist/include/jsapi.h
>>>
>>> maas@sendai /relax/couchdb
>>> $ more /relax/bin/couchdb_config_js185.sh
>>> #!/bin/sh
>>> COUCH_TOP=`pwd`
>>> export COUCH_TOP
>>>
>>> ./configure \
>>> --with-js-lib=/relax/js-1.8.5/js/src/dist/lib \
>>> --with-js-include=/relax/js-1.8.5/js/src/dist/include \
>>> ...
>>>
>>> A+
>>> Dave

Mime
View raw message