couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Randall Leeds (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (COUCHDB-1371) configure erroneously warns against using a new spidermonkey with old spidermonkeys
Date Sun, 25 Dec 2011 04:31:31 GMT

     [ https://issues.apache.org/jira/browse/COUCHDB-1371?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Randall Leeds updated COUCHDB-1371:
-----------------------------------

    Attachment: 0001-fix-bad-configure-warning-on-old-SpiderMonkey.patch

Here's a patch which fixes this. I'd like to apply it. Though, on a related note, I'd be glad
to drop support for 1.7 spidermonkey since the INSTALL files have already been updated to
say >= 1.8.
                
> configure erroneously warns against using a new spidermonkey with old spidermonkeys
> -----------------------------------------------------------------------------------
>
>                 Key: COUCHDB-1371
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1371
>             Project: CouchDB
>          Issue Type: Bug
>            Reporter: Randall Leeds
>            Assignee: Randall Leeds
>            Priority: Minor
>             Fix For: 1.2, 1.3, 1.1.2
>
>         Attachments: 0001-fix-bad-configure-warning-on-old-SpiderMonkey.patch
>
>
> Paul added the check for JSOPTION_ANONFUNFIX in 7ce9e103e, but js-1.7 doesn't have this
constant so configure gives a warning.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message