couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benoit Chesneau (Commented) (JIRA)" <>
Subject [jira] [Commented] (COUCHDB-1302) Fix couchjs
Date Fri, 07 Oct 2011 06:22:29 GMT


Benoit Chesneau commented on COUCHDB-1302:

I was thinking this morning on this function naming. I'm not sure it's really needed. Why
not considering map & other functions like code we just need to evaluate. Something like

        "map": "emit(doc._id, null);"

So we can eventually encapsulate it in our function. This pattern is commonly used. You can
found it for example in last redis script feature or in elasticsearch. It would also simplify
a lot the syntax and the way we can write and debug such functions. Thoughts ?
> Fix couchjs
> -----------
>                 Key: COUCHDB-1302
>                 URL:
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: JavaScript View Server
>    Affects Versions: 1.1.1, 1.2, 1.3
>            Reporter: Paul Joseph Davis
>            Priority: Blocker
> Figure out why some spidermonkeys have an error when doing: eval("function(){}")

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message