couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Weng Luu (JIRA)" <>
Subject [jira] [Created] (COUCHDB-1222) Naming convention: _id/_rev and id/rev
Date Thu, 14 Jul 2011 08:02:02 GMT
Naming convention: _id/_rev and id/rev

                 Key: COUCHDB-1222
             Project: CouchDB
          Issue Type: Improvement
            Reporter: Johnny Weng Luu

I'm using a MVC framework to communicate with CouchDB.

Sometimes CouchDB returns _id/_rev and other times id/rev.

Could either one of them be used instead, cause the model layer usually have pre set fields
that can't be changed.

And this would also not confuse developers when they are parsing the result.

Stick to one?

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message