couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Weng Luu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1222) Naming convention: _id/_rev and id/rev
Date Thu, 14 Jul 2011 13:33:05 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1222?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13065253#comment-13065253
] 

Johnny Weng Luu commented on COUCHDB-1222:
------------------------------------------

So I thought no problemo, CouchDB's _update function can fix this. But it doesn't return _rev.

So there is just no way making it simple for other frameworks to be compatible CouchDB.

You are basically saying: "We won't format the response so that you can work with CouchDB.
You have to write a specific CouchDB adapter".

If I use 2-3 different frameworks the chance is next to 0% that they all will work with CouchDB.
It's much better if CouchDB is flexible in the response data so that it can adapt to their
whatever model system.

Three solutions I mentioned could solve this:

1. Make _rev/_id being used all time.
2. Let the user choose to return the whole document on creation.
3. Return _rev also in _update function.

Isn't it worth to make CouchDB more compatible with other frameworks to gain more popularity?

> Naming convention: _id/_rev and id/rev
> --------------------------------------
>
>                 Key: COUCHDB-1222
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1222
>             Project: CouchDB
>          Issue Type: Improvement
>            Reporter: Johnny Weng Luu
>            Priority: Minor
>
> I'm using a MVC framework to communicate with CouchDB.
> Sometimes CouchDB returns _id/_rev and other times id/rev.
> Could either one of them be used instead, cause the model layer usually have pre set
fields that can't be changed.
> And this would also not confuse developers when they are parsing the result.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message