couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Newson (JIRA)" <>
Subject [jira] [Commented] (COUCHDB-1222) Naming convention: _id/_rev and id/rev
Date Thu, 14 Jul 2011 13:45:00 GMT


Robert Newson commented on COUCHDB-1222:

I don't think JIRA is a good place for a conversation, this is better done on the mailing
lists, though I think this particular topic has been beaten to death.

The _id vs id thing is a deliberate, long-standing decision that is not changing any time
soon. Please don't use JIRA as a forum. Bug reports are fine, of course, but discussing couchdb
belongs on a mailing list. Only once there's a proposal to change this is it appropriate to
file a ticket.

> Naming convention: _id/_rev and id/rev
> --------------------------------------
>                 Key: COUCHDB-1222
>                 URL:
>             Project: CouchDB
>          Issue Type: Improvement
>            Reporter: Johnny Weng Luu
>            Priority: Minor
> I'm using a MVC framework to communicate with CouchDB.
> Sometimes CouchDB returns _id/_rev and other times id/rev.
> Could either one of them be used instead, cause the model layer usually have pre set
fields that can't be changed.
> And this would also not confuse developers when they are parsing the result.

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message