couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Weng Luu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (COUCHDB-1222) Naming convention: _id/_rev and id/rev
Date Thu, 14 Jul 2011 08:03:59 GMT

     [ https://issues.apache.org/jira/browse/COUCHDB-1222?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Johnny Weng Luu updated COUCHDB-1222:
-------------------------------------

    Description: 
I'm using a MVC framework to communicate with CouchDB.

Sometimes CouchDB returns _id/_rev and other times id/rev.

Could either one of them be used instead, cause the model layer usually have pre set fields
that can't be changed.

And this would also not confuse developers when they are parsing the result.

  was:
I'm using a MVC framework to communicate with CouchDB.

Sometimes CouchDB returns _id/_rev and other times id/rev.

Could either one of them be used instead, cause the model layer usually have pre set fields
that can't be changed.

And this would also not confuse developers when they are parsing the result.

Stick to one?


> Naming convention: _id/_rev and id/rev
> --------------------------------------
>
>                 Key: COUCHDB-1222
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1222
>             Project: CouchDB
>          Issue Type: Improvement
>            Reporter: Johnny Weng Luu
>            Priority: Minor
>
> I'm using a MVC framework to communicate with CouchDB.
> Sometimes CouchDB returns _id/_rev and other times id/rev.
> Could either one of them be used instead, cause the model layer usually have pre set
fields that can't be changed.
> And this would also not confuse developers when they are parsing the result.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message