couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Weng Luu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1216) Rename _update to _save
Date Tue, 12 Jul 2011 10:00:59 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1216?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13063796#comment-13063796
] 

Johnny Weng Luu commented on COUCHDB-1216:
------------------------------------------

Yeah I think save is much more logical and follows web standards.

Often you do something like model.save() and it will either send a 'create' or 'update' action
depending on it's "newness".

> Rename _update to _save
> -----------------------
>
>                 Key: COUCHDB-1216
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1216
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: HTTP Interface
>            Reporter: Johnny Weng Luu
>            Priority: Trivial
>
> Since an update function can be used to either create or update a document, I think it's
more appropriate to rename it to _save.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message