couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johnny Weng Luu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1222) Naming convention: _id/_rev and id/rev
Date Thu, 14 Jul 2011 13:21:00 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1222?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13065244#comment-13065244
] 

Johnny Weng Luu commented on COUCHDB-1222:
------------------------------------------

Great explanation :)

But this leads to another problem. When creating a document CouchDB only returns id and rev.
You say that I shouldn't make a model out of that data, but that doesn't make sense.

Since I have to put the id and rev into the model that was creating the document, so that
the I can update the document. If I don't put id and rev inside the model, now I can't update
the document right?

CouchDB can solve this by returning the whole doc to me (with _id and _rev this time) on creation.
But that isn't on the Roadmap.

So it's a dilemma making it hard for frameworks to be CouchDB compatible.

And that is sad since CouchDB is so awesome.

> Naming convention: _id/_rev and id/rev
> --------------------------------------
>
>                 Key: COUCHDB-1222
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1222
>             Project: CouchDB
>          Issue Type: Improvement
>            Reporter: Johnny Weng Luu
>            Priority: Minor
>
> I'm using a MVC framework to communicate with CouchDB.
> Sometimes CouchDB returns _id/_rev and other times id/rev.
> Could either one of them be used instead, cause the model layer usually have pre set
fields that can't be changed.
> And this would also not confuse developers when they are parsing the result.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message