couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Newson (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (COUCHDB-1216) Rename _update to _save
Date Tue, 12 Jul 2011 09:51:00 GMT

     [ https://issues.apache.org/jira/browse/COUCHDB-1216?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Newson resolved COUCHDB-1216.
------------------------------------

    Resolution: Won't Fix

In couchdb we regard creation, update, and deletion of documents as 'updates', so the current
name reflects internal terminology.

I'm closing this as 'Won't Fix' but the idea could be helpful in defining a simpler and cleaner
API in couchdb 2.0, where we could make incompatible changes like this.

Thank you again for the suggestion.

> Rename _update to _save
> -----------------------
>
>                 Key: COUCHDB-1216
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1216
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: HTTP Interface
>            Reporter: Johnny Weng Luu
>            Priority: Trivial
>
> Since an update function can be used to either create or update a document, I think it's
more appropriate to rename it to _save.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message