couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <...@apache.org>
Subject Re: SpiderMonkey Version Support
Date Wed, 29 Jun 2011 16:46:56 GMT

On 29 Jun 2011, at 18:12, Paul Davis wrote:

> On Wed, Jun 29, 2011 at 4:14 AM, Dirkjan Ochtman <dirkjan@ochtman.nl> wrote:
>> On Wed, Jun 29, 2011 at 01:08, Paul Davis <paul.joseph.davis@gmail.com> wrote:
>>> *Nothing* should change on anything that isn't trunk.
>> 
>> You mean that 1.1 will never support SpiderMonkey 1.8.5? That would
>> kind of suck.
>> 
> 
> Its a fairly non-trivial patch as demonstrated by how long it took to
> even get into trunk. I don't think its proper fodder for a bug fix
> release. Also, not supporting 1.8.5 will motivate people to upgrade
> CouchDB as well.

Except if people have trouble installing / upgrading CouchDB, it leaves
a bad taste. I'd rather not put users between a rock (1.7-based
SpiderMonkey version) and a hard place (CouchDB only supporting 1.8.5
and up)

Cheers
Jan
-- 


> 
>>> Since 1.2 isn't more than a reference to trunk, there's not much (IMO)
>>> keeping us from dropping our support for everything pre-1.8.5 (except
>>> being nice to users I guess).
>> 
>> Doesn't that depend on when 1.2 comes out? 1.8.5 is not that old.
>> 
>> Cheers,
>> 
>> Dirkjan
>> 


Mime
View raw message