couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Joseph Davis (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1204) Cannot pull replicate with HTTPS (using native SSL) but works for same database with HTTP
Date Tue, 28 Jun 2011 15:09:17 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13056563#comment-13056563
] 

Paul Joseph Davis commented on COUCHDB-1204:
--------------------------------------------

Check here: http://www.erlang.org/download.html

> Cannot pull replicate with HTTPS (using native SSL) but works for same database with
HTTP
> -----------------------------------------------------------------------------------------
>
>                 Key: COUCHDB-1204
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1204
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Replication
>    Affects Versions: 1.1
>         Environment: Ubuntu 10.04 64bit, CouchDB 1.1.0, Erlang 1:13.b.3-dfsg-2ubuntu2.1,
Spidermonkey 3.5.15
>            Reporter: Simon Eisenmann
>              Labels: SSL, pull, replication
>
> I just tried out native SSL in CouchDB 1.1. SSL pull replication works fine for very
small databases. Though for long running older databases it never works. So this means having
CouchDB 1.1.0 running on Port 5984 non SSL and on 6984 SSL replication works for the first
but not for the second URL (same source database, same local target).
> This is the output for the non SSL replication:
> {"session_id":"8703d846d4a90184b5cdc4358ebbdec4","start_time":"Tue, 28 Jun 2011 14:57:15
GMT","end_time":"Tue, 28 Jun 2011 14:57:40 GMT","start_last_seq":0,"end_last_seq":1303811,"recorded_seq":1303811,"missing_checked":0,"missing_found":14965,"docs_read":14984,"docs_written":14984,"doc_write_failures":0}
> And this the error on the local CouchDB when trying this through SSL:
> <0.5735.8>,  {error,{badinfo,{tcp,#Port<0.10031>.  Futon outputs something
like Replication failed: {bad_term,<0.897.9>}
> The remote Couch does not have any error in the log.To me this seems to be an issue on
the receiving side.
> Both Couches are the same version and Platform (Ubuntu 10.04 64bit). 

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message