couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Coulson (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (COUCHDB-1078) Port couchjs to newest libmozjs
Date Tue, 14 Jun 2011 17:49:47 GMT

     [ https://issues.apache.org/jira/browse/COUCHDB-1078?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris Coulson updated COUCHDB-1078:
-----------------------------------

    Attachment: mozjs1.8.5.patch

Here is an updated patch.

This adds support for building with the Spidermonkey 1.8.5 tarball release (which ships a
pkg-config file), without having to specify --with-js-include or --with-js-lib. I've also
tried to tidy up some of the #ifdefs and make the code more readable by putting some macros
in a new header (jscompat.h). I'm not sure if this is the right approach, but fixing some
compiler warnings ended up adding even more #ifdef's to the original patch, so I did this
instead

> Port couchjs to newest libmozjs
> -------------------------------
>
>                 Key: COUCHDB-1078
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1078
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: JavaScript View Server
>    Affects Versions: 1.0.2
>            Reporter: Chris Coulson
>            Priority: Minor
>         Attachments: COUCHDB-1078.patch, couchjs_ff185.patch, mozjs1.8.5.patch, mozjs2.0.patch
>
>
> In the libmozjs shipped with Firefox 4 / xulrunner 2.0, jsapi has changed a fair bit.
It would be nice to add support to couchjs for the latest libmozjs so Linux distro's don't
have to support old versions of it.
> I already have a WIP patch for this

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message