couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Levirne <couc...@jakelevirne.com>
Subject Futon replicator_db and stats tests failing for me on 1.1.x
Date Fri, 20 May 2011 17:40:50 GMT
Hi All-

I had posted a note a little while back about futon tests failing for
me, but I was running against trunk.  I'm now running against a dev
build of the 1.1.x branch (make dev; utils/run) and still getting
futon test suite errors (below).  All my etap tests pass.

I'm new to the couchb community and looking for guidance on whether I
should file an issue for these or not.

replicator_db   failure 164016ms

  1. Run with debuggerAssertion failed: typeof
repDoc2._replication_state === "undefined"
  2. Assertion failed: typeof repDoc2._replication_state_time === "undefined"

stats   failure 49365ms

  1. Run with debuggerAssertion 'triggered, "We managed to force a
all_dbs_active error."' failed: We managed to force a all_dbs_active
error.


I also get a failure on view_sandboxing complaining about the
installed SpiderMonkey version:

view_sandboxing failure 8145ms

  1. Run with debuggerAssertion 'Warning: installed SpiderMonkey
version doesn't allow sealing of arrays' failed: expected '2', got '3'

But I installed from 1.8.0-rc1 source using these instructions:
http://wiki.apache.org/couchdb/Installing_SpiderMonkey

I'm on Ubuntu 10.04.2 64-bit server.  Browser is FF3.6.17 running on
Win7.  Here's my couch log file:
http://dl.dropbox.com/u/9276140/couch.log (it shows several server
terminations).  The run that produced the above errors starts at [Fri,
20 May 2011 15:38:23 GMT].  Also, here's my local_dev.ini:
http://dl.dropbox.com/u/9276140/local_dev.ini (though the only change
I made to it was to set the bind_address to 0.0.0.0).


Please let me know if there's any additional info I can provide to
help pinpoint the problem.

Thanks,
-Jake

Mime
View raw message