couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jake Levirne <couc...@jakelevirne.com>
Subject Re: Tips for getting past test suite errors
Date Wed, 11 May 2011 02:52:13 GMT
Thanks, Paul.  I'm using FF4.0.1 from my win7 machine to hit Futon.
One error seems to be triggered here in attachments.js:

var xhr = CouchDB.request("PUT", "/test_suite_db/bin_doc5/lorem.txt", {
headers:{"Content-Type":"text/plain;charset=utf-8"},
body:lorem
});
T(xhr.status == 201);

The actual status coming back is a 304 (Not Modified).  But let me
give the etap tests a shot.

Some more basic questions: should I generally be working against trunk
or a different branch?  Is it helpful for me to try to get the tests
all working (i.e. JIRA issues filed, with patches), or is that a
waste?


On Tue, May 10, 2011 at 9:23 PM, Paul Davis <paul.joseph.davis@gmail.com> wrote:
> Jake,
>
> What browser are you using? Officially we only support FF3.5 (unless
> that version changed recently?) but the tests generally work on all
> the WebKit browsers as well though occasionally they get out of whack
> and someone eventually gets pissed and fixes them so we don't have to
> run FF.
>
> Beyond that it looks like your environment is up to snuff. I'd expect
> many more failures if not. The last error I think is an on purpose one
> which just says your SM is a bit old. The others I've not heard
> reports of or seen myself though its been awhile since I've run the
> Futon tests on trunk.
>
> Also, for tests there's also the etap tests which you can run using
> `make check` that might also point at an error somewhere.
>
> Paul
>
> On Tue, May 10, 2011 at 5:09 PM, Jake Levirne <couchdb@jakelevirne.com> wrote:
>> Hello-
>>
>> I'm new to couchdb-dev and am trying to get to the point where I can
>> make useful contributions.  Right now 8 of my tests are failing when I
>> run the test suite in futon (details below).
>>
>> I'm running on an Ubuntu 10.04.2 Server virtualbox, and I've forked
>> and cloned apache/couchdb on github and am up to date with
>> git.apache.org/couchdb.git (so I think I have the latest trunk).
>>
>> I've followed these instructions for running couchdb in dev mode:
>> http://wiki.apache.org/couchdb/Running%20CouchDB%20in%20Dev%20Mode
>>
>> and I believe all my dependencies are in order (I  was able to
>> bootstrap, configure, and build successfully).  Are these errors
>> expected?  If not, any pointers for how to get started tracking down
>> what might be wrong with my setup?
>>
>> basics  success 14232ms
>> all_docs        success 6441ms
>> attachments     error   5699ms
>>
>>    Run with debugger
>>    Assertion failed: xhr.responseText == lorem
>>    Exception raised: {"message":"actual is
>> null","fileName":"http://192.168.2.13:5984/_utils/script/couch_test_runner.js?0.11.0","lineNumber":322,"stack":"TEqualsIgnoreCase(\"text/plain;charset=utf-8\",null)@http://192.168.2.13:5984/_utils/script/couch_test_runner.js?0.11.0:322\u000a(false)@http://192.168.2.13:5984/_utils/script/couch_test_runner.js?0.11.0:147\u000arun(0)@http://192.168.2.13:5984/_utils/script/couch_test_runner.js?0.11.0:91\u000a"}
>>
>> attachments_multipart   success 4498ms
>> attachment_names        success 1643ms
>> attachment_paths        success 3852ms
>> attachment_ranges       success 3046ms
>> attachment_views        success 2370ms
>> auth_cache      success 16065ms
>> batch_save      success 67251ms
>> bulk_docs       success 4190ms
>> changes success 19200ms
>> compact success 11128ms
>> config  success 4686ms
>> conflicts       success 2191ms
>> content_negotiation     success 1253ms
>> cookie_auth     success 12960ms
>> copy_doc        success 2367ms
>> delayed_commits success 25500ms
>> design_docs     success 40423ms
>> design_options  success 2835ms
>> design_paths    success 3316ms
>> erlang_views    success 5132ms
>> etags_head      failure 2012ms
>>
>>    Run with debugger
>>    Assertion failed: xhr.status == 304
>>
>> etags_views     success 12380ms
>> form_submit     success 558ms
>> http    success 1980ms
>> invalid_docids  success 1386ms
>> jsonp   success 2227ms
>> large_docs      success 1504ms
>> list_views      failure 6230ms
>>
>>    Run with debugger
>>    Assertion 'xhr.status == 200, "standard get should be 200"'
>> failed: standard get should be 200
>>    Assertion failed: /head0123456789tail/.test(xhr.responseText)
>>
>> lots_of_docs    success 1329ms
>> method_override success 1730ms
>> multiple_rows   success 2342ms
>> oauth   success 15701ms
>> proxyauth       success 5462ms
>> purge   success 8323ms
>> reader_acl      success 11426ms
>> recreate_doc    success 10891ms
>> reduce  success 38180ms
>> reduce_builtin  failure 50824ms
>>
>>    Run with debugger
>>    Assertion failed: db.info().doc_count == (i - 1) * 10 * 11 + (j + 1) * 11
>>
>> reduce_false    success 1184ms
>> reduce_false_temp       success 1171ms
>> replication     success 554998ms
>> replicator_db   failure 137115ms
>>
>>    Run with debugger
>>    Assertion failed: typeof repDoc2._replication_state === "undefined"
>>    Assertion failed: typeof repDoc2._replication_state_time === "undefined"
>>
>> rev_stemming    failure 10205ms
>>
>>    Run with debugger
>>    Assertion failed: db.open("bar", {revs:
>> true})._revisions.ids.length == newLimit + 1
>>    Assertion failed: db.open("bar", {revs:
>> true})._revisions.ids.length == newLimit + 1
>>
>> rewrite success 7711ms
>> security_validation     success 26567ms
>> show_documents  success 9692ms
>> stats   failure 43987ms
>>
>>    Run with debugger
>>    Assertion 'triggered, "We managed to force a all_dbs_active
>> error."' failed: We managed to force a all_dbs_active error.
>>
>> update_documents        success 5215ms
>> users_db        success 4339ms
>> utf8    success 3098ms
>> uuids   success 2186ms
>> view_collation  success 13409ms
>> view_collation_raw      success 7263ms
>> view_conflicts  success 2533ms
>> view_compaction success 5684ms
>> view_errors     success 7816ms
>> view_include_docs       success 7203ms
>> view_multi_key_all_docs success 3578ms
>> view_multi_key_design   success 5621ms
>> view_multi_key_temp     success 1158ms
>> view_offsets    success 23291ms
>> view_pagination success 15272ms
>> view_sandboxing failure 3380ms
>>
>>    Run with debugger
>>    Assertion 'Warning: installed SpiderMonkey version doesn't allow
>> sealing of arrays' failed: expected '2', got '3'
>>
>> view_update_seq success 10399ms
>> view_xml        success 1728ms
>>
>

Mime
View raw message