couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicholas Orr (JIRA)" <>
Subject [jira] [Commented] (COUCHDB-951) Test DB upgrade for 1.0.x to 1.1.0
Date Mon, 11 Apr 2011 03:29:05 GMT


Nicholas Orr commented on COUCHDB-951:

I ran this on my gentoo (2.6.36-gentoo-r8) amd64 vm _(3096MB RAM)_ with commit f9672572ac6db75fec6ba07c82fd26dbac7400ce

[apparently GNU dd only likes 1M as opposed 1m|]

as I ran i kept noticing issues, i ran it 3 times, i realised that couchdb was still
running from previous fails, so killed all 9 instances.
started again.

now curl chockes on the 75M doc..

+ curl -O
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 99 75.0M   99 74.9M    0     0  26.5M      0  0:00:02  0:00:02 --:--:-- 26.5M
curl: (18) transfer closed with 8192 bytes remaining to read

right, started couchdb again without going to the background and now i get an error, for some
reason it wasn't putting the error in the couchdb.log file..

everytime i curl i get this error

 1.1 $ ./bin/couchdb -a llocal.ini
Apache CouchDB 1.1.0a33f7a1b-git (LogLevel=info) is starting.
Apache CouchDB has started. Time to relax.
[info] [<0.33.0>] Apache CouchDB has started on
[info] [<0.718.0>] - - 'GET' /test-db/test-doc-75M/75M 200
[error] [<0.718.0>] Uncaught error in HTTP request: {error,
[info] [<0.718.0>] Stacktrace: [{io_lib_pretty,cind_tag_tuple,7},
[error] [<0.718.0>] {error_report,<0.32.0>,

=CRASH REPORT==== 11-Apr-2011::13:16:50 ===
    initial call: mochiweb_acceptor:init/3
    pid: <0.718.0>
    registered_name: []
    exception exit: {ucs,{bad_utf8_character_code}}
      in function  xmerl_ucs:from_utf8/1
      in call from mochijson2:json_encode_string/2
      in call from mochijson2:'-json_encode_proplist/2-fun-0-'/3
      in call from lists:foldl/3
      in call from mochijson2:json_encode_proplist/2
      in call from couch_httpd:send_json/4
      in call from couch_httpd:handle_request_int/5
      in call from mochiweb_http:headers/5
    ancestors: [couch_httpd,couch_secondary_services,couch_server_sup,
    messages: []
    links: [<0.114.0>,#Port<0.1984>]
    dictionary: [{mochiweb_request_qs,[]},
    trap_exit: false
    status: running
    heap_size: 6765
    stack_size: 24
    reductions: 267779

i ran the same get on the 1.0 and this error doesn't pop up. able to download the 75M doc
just fine

gentoo 1.1 #  erl
Erlang R13B04 (erts-5.7.5) [source] [64-bit] [smp:3:3] [rq:3] [async-threads:0] [kernel-poll:false]

Eshell V5.7.5

what other info do you need to see this work?
I can give you ssh access to this vm if that is easier, the error doesn't make much sense
to me...

> Test DB upgrade for 1.0.x to 1.1.0
> ----------------------------------
>                 Key: COUCHDB-951
>                 URL:
>             Project: CouchDB
>          Issue Type: Test
>    Affects Versions: 1.1
>            Reporter: Robert Newson
>            Assignee: Robert Newson
>             Fix For: 1.1
> As the on-disk format has changed (for Range header support for attachments) extensive
testing of db upgrades should be performed.
> The Range upgrade occurs on compaction, so it should suffice to;
> 1) create a db with 1.0.x
> 2) upgrade to 1.1.0
> 3) compact
> 4) verify db
> I will be working on scripts to automate as much as possible.

This message is automatically generated by JIRA.
For more information on JIRA, see:

View raw message