couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Joseph Davis (JIRA)" <j...@apache.org>
Subject [jira] Commented: (COUCHDB-1078) Port couchjs to newest libmozjs
Date Tue, 01 Mar 2011 16:02:37 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1078?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13000927#comment-13000927
] 

Paul Joseph Davis commented on COUCHDB-1078:
--------------------------------------------

How far back does support go? IIRC this patch drops support for 1.7 which is a bit of a jump
that we'd want to consider.

In regards to the patch itself, I'd drop the conditional compilation of couch_fgets and just
use it for everything. As to the various other conditional compilation parts I'd rather see
these bits sequested to a couple source and/or headers that are conditionally included. Reading
through the patch makes my brain hurt a bit.

> Port couchjs to newest libmozjs
> -------------------------------
>
>                 Key: COUCHDB-1078
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1078
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: JavaScript View Server
>    Affects Versions: 1.0.2
>            Reporter: Chris Coulson
>            Priority: Minor
>         Attachments: mozjs2.0.patch
>
>
> In the libmozjs shipped with Firefox 4 / xulrunner 2.0, jsapi has changed a fair bit.
It would be nice to add support to couchjs for the latest libmozjs so Linux distro's don't
have to support old versions of it.
> I already have a WIP patch for this

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message