couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filipe Manana (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (COUCHDB-1081) Proper database header upgrade
Date Wed, 09 Mar 2011 20:09:59 GMT

     [ https://issues.apache.org/jira/browse/COUCHDB-1081?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Filipe Manana resolved COUCHDB-1081.
------------------------------------

       Resolution: Fixed
    Fix Version/s: 1.2

Applied the second part of the patch (avoiding the function_clause error when opening unsupported
database versions) to trunk.

> Proper database header upgrade
> ------------------------------
>
>                 Key: COUCHDB-1081
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1081
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Database Core
>            Reporter: Filipe Manana
>            Assignee: Filipe Manana
>             Fix For: 1.2
>
>         Attachments: COUCHDB-1081.patch
>
>
> After upgrading an old database header, we don't set the disk_version field of the upgraded
header to the latest supported version.
> Also, when opening versions from more recent releases, we get a function clause crash
instead of throwing an exception with an explicit message informing the version is not supported.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message