couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Young <benja...@couchone.com>
Subject Re: rewriter needed changes
Date Thu, 20 Jan 2011 16:27:35 GMT
On 1/20/11 10:45 AM, Benoit Chesneau wrote:
> On Thu, Jan 20, 2011 at 4:40 PM, Volker Mische<volker.mische@gmail.com>  wrote:
>
>> {
>>   "from": "/page/:x/:y/:z",
>>   "to": "/_show/post/:x-:y-:z/something",
>>   "params": {
>>     "x": {
>>     "match": "\\d",
>>   },
>>     "y": {
>>     "match": "\\d",
>>   },
>>     "z": {
>>     "match": "\\d",
>>   }
>> }
>>
> This one is already possible in current couchapp_legacy rewriter. I'm
> not a fan to have something other than :
>
> patterns: {
>      "name1": "regexp",
>       ...
> }
>
> It will make the system really complex. Maybe as an option though. I
> can detect if I have an object or not. I think it would be better to
> say ".*"
>
>
>   (and i need to find a new name for couchapp_legacy)
>
>
> - benoît
I couldn't speak to the complexity of the code as I'm fairly new to 
Erlang. In any case, I think we need to keep the URL's in "from" and 
"to" easy to read and provide flexible parsing options with a "standard" 
(or standard set) available by default.

If we support regular expressions, I'd suggest using PCRE over any other 
as its widely known and used (Django, nginx, PHP, mod_rewrite).

Mime
View raw message