couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benoit Chesneau <bchesn...@gmail.com>
Subject Re: builting changes filter functions
Date Sat, 13 Nov 2010 18:49:22 GMT
On Sat, Nov 13, 2010 at 6:19 PM, Filipe David Manana
<fdmanana@apache.org> wrote:
> Without going into very deep analysis yet (no time this weekend):
>
> - I would prefer _doc_ids instead of _docids for the filter name =>
> besides being more readable, it will match the query parameter (named
> doc_ids) and the equivalent replicator option
>
> - In code variables, DocIds is also more readable than Docids - but
> this is just my very personal taste, and I understand Pythoners are
> used to alllowercasegluedwordscompletelyunreadable :)
>
I personnaly prefer Docids, since i just use caps to tell me that's a
var, but anyway since we already use DocId in th the code I renamed it
:) _docids -> _doc_ids too .

> good work BenoƮt
>
Thanks. If it's ok for everyone I will commit it later tonight.


 What's the deadline for 1.1 btw? Trying to know if I have time to
finish the new _rewrite handler ?


- benoit

Mime
View raw message