couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filipe David Manana <fdman...@apache.org>
Subject Re: builting changes filter functions
Date Sat, 13 Nov 2010 23:05:26 GMT
On Sat, Nov 13, 2010 at 6:49 PM, Benoit Chesneau <bchesneau@gmail.com> wrote:
> On Sat, Nov 13, 2010 at 6:19 PM, Filipe David Manana
> <fdmanana@apache.org> wrote:
>> Without going into very deep analysis yet (no time this weekend):
>>
>> - I would prefer _doc_ids instead of _docids for the filter name =>
>> besides being more readable, it will match the query parameter (named
>> doc_ids) and the equivalent replicator option
>>
>> - In code variables, DocIds is also more readable than Docids - but
>> this is just my very personal taste, and I understand Pythoners are
>> used to alllowercasegluedwordscompletelyunreadable :)
>>
> I personnaly prefer Docids, since i just use caps to tell me that's a
> var, but anyway since we already use DocId in th the code I renamed it
> :) _docids -> _doc_ids too .

Great! Even because we have _all_docs and not _alldocs for e.g.

>
>> good work Benoît
>>
> Thanks. If it's ok for everyone I will commit it later tonight.
>
>
>  What's the deadline for 1.1 btw? Trying to know if I have time to
> finish the new _rewrite handler ?

I have no idea.
>
>
> - benoit
>



-- 
Filipe David Manana,
fdmanana@gmail.com, fdmanana@apache.org

"Reasonable men adapt themselves to the world.
 Unreasonable men adapt the world to themselves.
 That's why all progress depends on unreasonable men."

Mime
View raw message