couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Kocoloski <kocol...@apache.org>
Subject Re: adding new macro to couch_db.hrl
Date Mon, 27 Sep 2010 18:04:31 GMT
I don't like "get" because it clashes with the auto-imported erlang:get (for the process dictionary).

Any reason to prefer a macro over an -import statement?

Adam

On Sep 27, 2010, at 1:47 PM, Filipe David Manana wrote:

> Hi,
> 
> I'm getting tired of typing couch_util:get_value(......). It also
> consumes too much horizontal space. It's probably the most used
> function from couch_util.
> I'm thinking of adding a new macro in couch_db.hrl, like:
> 
> -define(value(Key, List), couch_util:get_value(Key, List)).
> 
> -define(value(Key, List, Default), couch_util:get_value(Key, List, Default)).
> 
> Or maybe naming the macro just "get".
> 
> Anyone against it?
> 
> 
> cheers
> 
> -- 
> Filipe David Manana,
> fdmanana@gmail.com, fdmanana@apache.org
> 
> "Reasonable men adapt themselves to the world.
>  Unreasonable men adapt the world to themselves.
>  That's why all progress depends on unreasonable men."


Mime
View raw message