couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filipe David Manana <>
Subject adding new macro to couch_db.hrl
Date Mon, 27 Sep 2010 17:47:08 GMT

I'm getting tired of typing couch_util:get_value(......). It also
consumes too much horizontal space. It's probably the most used
function from couch_util.
I'm thinking of adding a new macro in couch_db.hrl, like:

-define(value(Key, List), couch_util:get_value(Key, List)).

-define(value(Key, List, Default), couch_util:get_value(Key, List, Default)).

Or maybe naming the macro just "get".

Anyone against it?


Filipe David Manana,,

"Reasonable men adapt themselves to the world.
 Unreasonable men adapt the world to themselves.
 That's why all progress depends on unreasonable men."

View raw message