couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Cohnen <sebastiancoh...@googlemail.com>
Subject Re: [VOTE] Apache CouchDB 1.0.0 release, second round
Date Fri, 09 Jul 2010 20:09:15 GMT
On 09.07.2010, at 21:55, J Chris Anderson wrote:

> 
> On Jul 9, 2010, at 12:44 PM, Sebastian Cohnen wrote:
> 
>> OS X 10.6.4, Erlang R13B04, Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
>> 
> 
> Have you ensured that you've cleared the browser cache?

I run Firefox in safemode, when running the test suite. but running it in normal mode (with
firebug & co) I always clear the cache. so yes, I ensured that the cache was empty. (I
begin to dislike a browser-based integration test suite more and more).

> Also, with Couch running on 5984, what do you get if you run this from the source directory:
> 
> test/javascript/run (I get some failures like this, no biggie, but changes passes)

"ok 11 changes" looks okay. but after some tests (e.g. "ok 26 http") it simply freezes. I've
waited a few minutes, killed both couch and the test and tried again. after the 10th run,
the test suite runs through (with "not ok 16 cookie_auth TypeError: ddoc is null" and "not
ok 43 replication ReferenceError: $ is not defined").


Sebastian

> Chris
> 
>> signature, make check, all okay. test suite: all okay, but the changes test however
always fails (Exception raised: "timeout: bar-only") when I run all test, I've tried about
10 times now. when I run this test in isolation it is successful most of the time, but not
always 3 fails out of 10. I have not yet pinpoint the responsible part of the test, that causes
the failure, but I notice, that for long periods of time the test simply does nothing (I see
"[info] [<0.8991.0>] 127.0.0.1 - - 'GET' /test_suite_db/_changes?feed=continuous&timeout=500
200" and then nothing for about a minute).
>> 
>> -1 (unless someone can tell me, what I could have done wrong)

*snip*


Mime
View raw message